[solved] Unable to install sync-Setup.exe

  • Upon launching, "sync-Setup.exe" it pops up a window saying it's preparing something briefly and then immediately closes.  Is there a log file someplace or some way to debug this?  I also have Six Updater installed if that makes a difference...

  • withSIX

    Greetings firefly,

    The installation window is by design, it installs some important elements that allow the client to communicate with the website. The installation of Sync quite small and automated, how do you know that it is not installed, Have you tried to search for "sync" ? Upon installation it should show up as an icon in the right side of the task bar.

    Also make sure that PwS is not running next to sync.

  • Yes, I tried searching for "sync" but I don't see anything.  What directory does it get installed to?  PwS is not running during/after install.

  • withSIX

    [quote=firefly2442] PwS is not running during/after instal[/quote]it should be here: C:\Users\Username\AppData\Local\syncbeta

    what windows version are you running?

  • Windows 7.  Ahh ok, so the folder is there and it looks like it's installed.  If I run "\syncbeta\app-1.0.1264.7\sync.exe", nothing seems to happen.  I don't see anything in the taskbar.  I have "always show all icons and notifications" checked under the options for the taskbar.  I don't see "sync" listed anywhere in the notification settings in windows.  Is there a startup log or some way to run with debugging or verbose output?

  • withSIX

    This indeed appears to be some strange issue, the only thing I can think of right now is that you might have an antivirus software or settings that prevent the installation, maybe due to lack of administrative rights.

    In any case I will bring the issue up with our dev team, they surely will be able to help

    Stay tuned, thanks for your patience.

  • @Sonsalt same problem. I have windows 10 pro. Please help us, i want to be playsix premium for a better experience.

  • withSIX

    @firefly2442 hi, you can find the logs in C:\users\your name\appdata\local\six networks\sync
    please send em over dropbox or similar :) thanks!

  • Ahha, thank you.  I solved the issue.  Here was the error:

    2015-12-18 20:03:35.3404|INFO|SN.withSIX.Mini.Presentation.Wpf.NLogSplatLogger|Startup, processing arguments: --help
    2015-12-18 20:03:35.4314|ERROR|SN.withSIX.Mini.Presentation.Wpf.NLogSplatLogger|An error occurred during processing startup:
    SN.withSIX.Core.Services.Infrastructure.ProcessException: netsh [6348] error: 1 while running: C:\Windows\system32\cmd.exe /C ""netsh" http show urlacl" from
    Error: '"netsh"' is not recognized as an internal or external command,
    operable program or batch file.
       at SN.withSIX.Core.Infra.Services.ProcessManager.LaunchAndGrabTool(ProcessStartInfo startInfo, String tool)
       at SN.withSIX.Core.Infra.Services.ProcessManager.LaunchAndGrabToolCmd(ProcessStartInfo info, String tool)
       at SN.withSIX.Mini.Infra.Api.ServerInfo.IsHttpRegistered(IProcessManagerSync pm, String value)
       at SN.withSIX.Mini.Infra.Api.ServerInfo..ctor(IProcessManagerSync pm)
       at SN.withSIX.Mini.Presentation.Wpf.Entrypoint.HandlePorts()
       at SN.withSIX.Mini.Presentation.Wpf.Entrypoint.TryHandlePorts()
       at SN.withSIX.Mini.Presentation.Wpf.Entrypoint.Main()

    The problem was C:\Windows\System32 was not in my environment variables path.  I added that and it installed and opened up.  Perhaps you could do an additional check for this or provide some type of warning if it's not identified?  Thanks for the help.

Log in to reply

Looks like your connection to withSIX Community was lost, please wait while we try to reconnect.