Failure to install?



  • Whenever I attempt to run SyncSetup.exe i get this error

    The logs are gibberish to me so I was hoping someone could possibly decipher whats going wrong. This is happening with the PWS client and the beta of PWS and SyncWithSix. I am on Windows 10.

    2016-08-31 19:45:41> Program: Starting Squirrel Updater: --install .
    2016-08-31 19:45:41> Program: Starting install, writing to C:\Users\Dylan\AppData\Local\SquirrelTemp
    2016-08-31 19:45:41> Program: About to install to: C:\Users\Dylan\AppData\Local\Sync
    2016-08-31 19:45:41> CheckForUpdateImpl: Couldn't write out staging user ID, this user probably shouldn't get beta anything: System.IO.DirectoryNotFoundException: Could not find a part of the path 'C:\Users\Dylan\AppData\Local\Sync\packages.betaId'.
    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
    at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
    at System.IO.StreamWriter.CreateFile(String path, Boolean append, Boolean checkHost)
    at System.IO.StreamWriter..ctor(String path, Boolean append, Encoding encoding, Int32 bufferSize, Boolean checkHost)
    at System.IO.File.InternalWriteAllText(String path, String contents, Encoding encoding, Boolean checkHost)
    at System.IO.File.WriteAllText(String path, String contents, Encoding encoding)
    at Squirrel.UpdateManager.CheckForUpdateImpl.getOrCreateStagedUserId()
    2016-08-31 19:45:41> CheckForUpdateImpl: Failed to load local releases, starting from scratch: System.IO.DirectoryNotFoundException: Could not find a part of the path 'C:\Users\Dylan\AppData\Local\Sync\packages\RELEASES'.
    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
    at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
    at Squirrel.Utility.LoadLocalReleases(String localReleaseFile)
    at Squirrel.UpdateManager.CheckForUpdateImpl.<CheckForUpdate>d__2.MoveNext()
    2016-08-31 19:45:41> CheckForUpdateImpl: Reading RELEASES file from C:\Users\Dylan\AppData\Local\SquirrelTemp
    2016-08-31 19:45:41> CheckForUpdateImpl: First run or local directory is corrupt, starting from scratch
    2016-08-31 19:45:41> ApplyReleasesImpl: Writing files to app directory: C:\Users\Dylan\AppData\Local\Sync\app-1.5.9
    2016-08-31 19:45:42> ApplyReleasesImpl: Squirrel Enabled Apps: [C:\Users\Dylan\AppData\Local\Sync\app-1.5.9\Sync.exe]
    2016-08-31 19:45:42> ApplyReleasesImpl: Couldn't run Squirrel hook, continuing: C:\Users\Dylan\AppData\Local\Sync\app-1.5.9\Sync.exe: System.ComponentModel.Win32Exception (0x80004005): The requested operation requires elevation
    at System.Diagnostics.Process.StartWithCreateProcess(ProcessStartInfo startInfo)
    at System.Diagnostics.Process.Start()
    at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
    at Squirrel.Utility.<InvokeProcessAsync>d__11.MoveNext()
    --- End of stack trace from previous location where exception was thrown ---
    at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    at Squirrel.UpdateManager.ApplyReleasesImpl.<>c__DisplayClass10_0.<<invokePostInstall>b__0>d.MoveNext()
    2016-08-31 19:45:44> ApplyReleasesImpl: Starting fixPinnedExecutables
    2016-08-31 19:45:44> ApplyReleasesImpl: Examining Pin: Google Chrome.lnk
    2016-08-31 19:45:44> ApplyReleasesImpl: Examining Pin: Spotify.lnk
    2016-08-31 19:45:44> ApplyReleasesImpl: Examining Pin: Steam.lnk
    2016-08-31 19:45:44> ApplyReleasesImpl: Fixing up tray icons
    2016-08-31 19:45:44> ApplyReleasesImpl: Failed to delete key: C:\Users\Dyl


  • withSIX

    Greetings,

    this can be related to some MS framework, but I can not say for sure. I have forwarded your issue to the developer, he will get back to you first thing in the morning.

    Hang in there,

    best regards


  • withSIX

    Try to run the setup right-click "Run as Administrator".



  • Just an update, managed to get the client to install by downloading some microsoft framework I did not have. However now that I have closed the client I cannot get it to relaunch. I am running as admin and everything but when i run the program, the run as admin prompt comes up and then nothing happens afterwards. Any help is appreciated, thanks!


  • withSIX

    @GriffDawg heya, do you have FireFox installed, is it running while you try to start the app?
    If still issues please send the logs from C:\users{yourname}\appdata\local\SIX Networks
    Preferably over dropbox, mega, or some similar service, otherwise email to support (at) withsix (dot) com
    thanks!



  • I do not have firefox installed or running at any time.

    PWS client is still failing to launch, I'll reach out thru email. Thanks.



  • Any update on whether the issue has been found?


  • withSIX

    The Developer is available again tomorrow morning, he will respond right away :)


  • withSIX

    @GriffDawg hi, so far it seems the last time the client ran everything was fine.
    Perhaps the window somehow ended up outside of the screen space? Do you find a play with six icon in the taskbar, or the tray notification area?

    Here's a guide on how to get a window visible again http://www.howtogeek.com/howto/windows/bring-misplaced-off-screen-windows-back-to-your-desktop-keyboard-trick/


Log in to reply
 

Looks like your connection to withSIX Community was lost, please wait while we try to reconnect.